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Unit 1: Functional English
	Q1.	 What are resolutions?
	Ans.	 Resolutions are promises that one basically makes to oneself.

	W2.	 What is adverb?
	Ans.	 An adverb describes the features of verbs, adjectives or other adverbs.

	Q3.	 What is an appetiser?
	Ans.	 It is taken before the main meal to stimulate one’s appetite.

	Q4.	 Define tenses.
	Ans.	 Tenses in English are forms of verbs that are used to indicate the time of happening of an event/action.

	Q5.	 What is a preposition?
	Ans.	 A preposition is a word that forms a link between a noun or pronoun and other words in a sentence. Some 

examples of prepositions are in, to, after, on and with.

	Q6.	 What are modals?
	Ans.	 Modal verbs express a speaker’s attitude and the attitude’s strength.

	Q7.	 What are tenses? List its different types.
	Ans.	 Tenses in English are forms of verbs that are used to indicate the time of happening of an event/action. There 

are mainly three types of tenses in English—present, past and future. Each of these tenses is further categorised 
into four types and can indicate whether an event occurs in the present, has taken place in the past or will be 
happening in the future.

		  Four types of present tense are as follows:

�� Simple present tense

�� Present continuous tense (or present progressive tense)

�� Present perfect tense

�� Present perfect continuous tense (or present perfect progressive tense)

		  Four types of past tense are as follows:

�� Simple past tense

�� Past continuous tense (or past progressive tense)

�� Past perfect tense

�� Past perfect continuous tense (or past perfect progressive tense)

		  Four types of future tense are as follows:

�� Simple future tense
�� Future continuous tense (or future progressive tense)
�� Future perfect tense
�� Future perfect continuous tense (or future perfect progressive tense)

	Q8.	 What is an outing? Explain.
	Ans.	 An outing is a short trip either within or out of the town for recreational purposes. It can also be a sort of one-

day picnic, visit to zoo or museum or a short stay at someone’s place or a hotel. Whatever it might be, you need 
to plan for an outing.
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		  Following phrases are used to suggest for an outing:

	 1.	 Hey! Let’s go somewhere.

	 2.	 Why don’t we go somewhere?

	 3.	 Let’s go for a picnic.

	 4.	 Shall we all go on lunch this weekend?

	 5.	 How about a shopping trip?

		  Following phrases are used to plan an outing:

	 1.	 Let’s book a cab.

	 2.	 I will take care of the train tickets.

	 3.	 Bring water bottles as it would be hot there.

	 4.	 Can you book the movie tickets?

	 5.	 Let’s meet at six outside the restaurant.

	Q9.	 Write a brief note on descriptive writing.
	Ans.	 Descriptive writing is a form of literary style in which objects, places and persons are described in such a detail 

that readers can almost form a picture in their minds.

		  This style of writing is different from the narrative style. Unlike a narrative essay, a descriptive essay employs 
the power of language and sensory observation to bring a subject or surrounding to life.

		  Some examples of descriptive writing are as follows:

	 1.	 Cindrella’s gown was as blue and bright as the sky on a clear sunny day.

	 2.	 The house had two big rooms and a study room adjoining the wall of the kitchen.

	 3.	 The grass in the garden was wet and cool to touch.

	Q10.	What is the difference between ‘commission’ and ‘security’?
	Ans.	 Commission: The amount the agent/broker earns by finalising the deal.

		  Security: The amount to be paid to the landlord before taking up the place. Usually, the security deposit equals 
to one-month rent.

Unit 2: Web Application (Basic)
	Q1.	 Define web accessibility.
	Ans.	 It refers to the phenomenon of designing and developing technologies, tools and web applications so that they 

can be easily used by people with disabilities.

	Q2.	 What are the basic components of a network?
	Ans.	 A network usually comprises five basic components – server, client, channels, operating system and interface. 

Servers are powerful host computers that store data and execute applications. Clients are computers connected 
to the server that use the network and shared resources. Channels are circuits or pathways connecting networks 
through which different interconnected computers share the information. Network operating system is the 
operating system software on the server. Interface devices connect server and clients.

	Q3.	 Define network topology. What are the common network topologies?
	Ans.	 Network topology refers to the basic geometric layout according to which the server and clients are connected 

via a channel. The three most common network topologies are bus, ring and star.



Practice Test Answers-Class X4

	Q4.	 Explain network types on the basis of component role.
	Ans.	 On the basis of component role, networks are classified as follows:

�� Peer-to-peer network: In this type of network, all the connected computers are equal, i.e., none of these is 
the sole in-charge of the operations of the network. In other words, each computer maintains its information 
and can serve both as a server as well as a client whenever required.

�� Server-based network: A dedicated server controls all the network operations and security. The dedicated 
server stores data, applications, and peripheral resources and makes them accessible to the clients.

�� Client-based network: This type of network employs the processing power of client workstation to execute 
some functions locally and requesting further processing from the server.

	Q5.	 What are the different types of blogs available on Internet?
	Ans.	 The blogs can be of various types, some of which are as follows:

�� Personal blogs: These types of blogs are developed by a user for his/her personal use. It is just like 
maintaining a personal diary online. It is generally created by an individual and not by an organisation. 
Generally, personal blogs are viewed by the immediate family members and friends of the blogger.

�� Corporate and organisational blogs: These types of blogs are created to generate business. These types of 
blogs are generally used by organisations, corporations, etc.

�� Genre blogs: These types of blogs contain information, articles and discussions related to a particular 
subject. Examples of genre blogs are art blogs, fashion blogs, music blogs and political blogs.

	Q6.	 List some reasons for using an offline blog editor.
	Ans.	 Following are some compelling reasons for using an offline blog editor:

�� No reliability on the internet: You are not required an active internet connection for writing web page 
content in an offline blog editor. Even if the internet connection goes down or the server is temporarily 
suspended, you will not lose any work. Your blog post will be stored in your hard drive until you press the 
publish button in the editor.

�� Easily and quickly upload videos and images: With offline editors, you can easily and automatically publish 
images and videos by merely hitting the publish button.

�� Speed: An offline editor works on your computer system. Therefore, you can easily create web content 
without relying on the internet connection. You require the internet only for publishing the posts. Rest of 
the work can be quickly done offline.

	Q7.	 List the steps involved in payment authorisation and payment settlement.
	Ans.	 The payment authorisation process involves the following steps:

	 1.	 A customer purchases an item on a website using a debit card or credit card.

	 2.	 The payment information is received by the payment gateway which encrypts the received data to ensure 
privacy and forwards the same to the payment processing system.

	 3.	 The payment processor sends a payment request to the issuing bank of the customer to ensure the customer 
has enough credit in his account to pay for the bills.

	 4.	 The issuing bank responds with an approval or a denial accordingly.

	Q8.	 What are the challenges involved in networking?
	Ans.	 Despite so many advantages, networking also involves some challenges and risks as follows:

�� Setup cost: Setting up a network involves investing in software and hardware equipment. The costs 
may seem inexpensive for a small network or a few computers but can overrun budgets in case of large 
companies involving many computers and geographically dispersed offices.

�� Administration cost: Networked computers require ongoing management and administration. Large 
companies often need to hire dedicated network administrator teams for managing large networks.
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�� Undesirable sharing: Sometimes, people may share undesirable data such as a virus that causes more harm 
than benefit. Mitigating the effects of such data involves high cost, more time and great administrative 
efforts.

	Q9.	 Write the Windows 7 accessibility features.
	Ans.	 Windows 7 generally provides some common accessibility features which can be categorised as follows:

�� Accessibility features for visually impaired users: People with limited eyesight can benefit from features like 
text-to-speech, enlarged cursor and high-contrast themes.

�� Accessibility features for low-hearing or deaf users: Features like closed-captioning, help in visually 
conveying the information to deaf users. Mono audio systems can equally transmit left and right audio 
signals to both the earbuds so that people with limited hearing do not miss any part of the audio.

�� Accessibility features for limited mobility users: Keyboard shortcuts and sticky keys help people with 
limited mobility in effectively using the computer.

	Q10.	How does instant messaging work?
	Ans.	 For using instant messaging services, users need to install an instant messaging software application. The 

software program enables a computer with an IM client to use instant messaging features. The user is 
registered on the IM client (IM software) with a unique password and username combination. The user uses 
these credentials to connect to the IM server for sending and receiving messages. Once a user logs in with the 
correct credentials, the connection information such as port number and IP address of the user are sent to the 
IM server. The server, in turn, creates a temporary file holding the information of the client. The server also 
checks the list of contacts of the client to see if any of them is also logged in and available for communication. 
In case the server finds an online connection, it sends the information back to the client. Also, the server sends 
the information about the client to the online contact. The information exchange allows both the users to 
communicate with each other either directly or via server.

		  The Internet Service Provider (ISP) plays an important role in instant messaging by delivering the client system 
information to the IM server. It also delivers messages and data between clients. Many modern IM softwares 
support various other features along with sending and receiving messages. These features include group chat 
with selected contacts in the list, sharing of multimedia like images, videos, and other files, mobile support, 
and sharing website links. IM clients can provide information about the presence and availability of a user. In 
addition to that, users can create a block list to explicitly bar selected contacts from getting user information, 
and allow a list of persons’ IDs who can track user information.

Unit 3: Word Processing (Intermediate)
	Q1.	 What do you understand by style in MS Word?
	Ans.	 Style refers to a set of formatting commands, such as font, font size, bold, underline and text color.

	Q2.	 What is the term Italic in MS Word?
	Ans.	 Italic is a font style that emphasises the selected text by making it slightly bent, that is forward inclined.

	Q3.	 Define the term “toggle case”.
	Ans.	 In toggle casing, all the letters of each word except the first letter are dcapitalised.

	Q4.	 What do you mean by page break in MS Word?
	Ans.	 A page break refers to a part in the document that separates two consecutive pages.
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	Q5.	 Write the steps to insert footer in a document.
	Ans.	 The steps to insert footer in a document are: 

	 1.	 Open a document in which you want to insert the footer.

	 2.	 Click the Footer button under the Header & Footer group of the Insert tab to insert footer.

		  A gallery of footer design appears.

	 3.	 Select the desired Footer design from the gallery. 

		  The footer appears at the bottom of every page in the document.

	 4.	 Type your own text in place of the preformatted text in the footer.

	 5.	 Click the Close Header and Footer button under the Close group of the Design tab.

		  The footer now appears at the bottom of each page in the document.

	Q6.	 What is paragraph indentation? Explain its types.
	Ans.	 Indentation refers to the space between the text and the page margins. Setting indent for a paragraph means 

setting left and right margins of the paragraph or text. You can indent a single paragraph or multiple paragraphs.

		  Different types of indentation are as follows:

�� Left: Specifies the left indent.

�� Right: Specifies the right indent.

�� First line: Specifies the first line indent.

�� Hanging: Keeps the text a little inward from the first line.

	Q7.	 What is a “Header” and when should it be used?
	Ans.	 Header is a section that appears at the top of each page between the top margin and the first line of the text. 

Any text or graphic that you insert in a header appears at the top of every page in the document. A typical 
header includes the document’s title and author name and dates of creation and modification of the document. 
You can also insert the pictures in the header, which is helpful when you add any logo in the document.

	Q8.	 Write the steps of line spacing in a document.
	Ans.	 The steps of line spacing in a document are as follows:

	 1.	 Open a document that contains the text whose line and spacing you want to set.

	 2.	 Select the paragraph whose line spacing you want to set.

	 3.	 Click the Paragraph dialog box launcher under the Paragraph group of the Home tab.

		  The Paragraph dialog box appears. This dialog box contains two tabs: Indents and Spacing and Line and Page 
Breaks.

	 4.	 Select the Indents and Spacing tab in the Paragraph dialog box.

	 5.	 Select the desired line spacing from the Line spacing drop-down list.

	 6.	 Click the OK button on the Paragraph dialog box.

		  The line spacing of the selected paragraph is changed.

	Q9.	 Write the steps to crop a picture in an MS Word 2010 document.
	Ans.	 The steps to crop a picture in an MS Word 2010 document are as follows:

	 1.	 Open a Word document.

	 2.	 Select the picture that you want to crop.

		  A Format tab appears in the Picture Tools contextual tab.
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	 3.	 Click the upper part of the Crop button under the Size group of the Format tab. The cropping handle appears 
around the picture.

	 4.	 Click any of the cropping handles around the picture.

	 5.	 Drag the mouse pointer up to the area where you want to crop the picture.

	 6.	 Release the mouse button.

	 7.	 Press the Enter key to crop the picture.

		  The picture is cropped within the specified area.

	Q10.	Define cropping and write the steps to crop a picture in an MS Word 2010 document.
	Ans.	 Cropping an image is similar to trim or reduce the size of the image in a document. MS Word 2010 provides 

certain controllers to edit the image in a document.

		  The steps to crop a picture in an MS Word 2010 document are -

	 1.	 Open a Word document.

	 2.	 Select the picture that you want to crop.

		  A Format tab appears in the Picture Tools contextual tab.

	 3.	 Click the upper part of the Crop button under the Size group of the Format tab. The cropping handle appears 
around the picture.

	 4.	 Click any of the cropping handles around the picture.

	 5.	 Drag the mouse pointer up to the area where you want to crop the picture.

	 6.	 Release the mouse button.

	 7.	 Press the Enter key to crop the picture.

		  The picture is cropped within the specified area.

Unit 4: Spreadsheet (Intermediate)
	Q1.	 Define conditional formatting.
	Ans.	 Conditional formatting is a powerful tool in Microsoft Excel that allows you to format a cell or range of cells 

based on specific conditions. These conditions are based on the data or value present in the cell. When the value 
of the cell satisfies the condition, the condition format you have selected is applied to the cell.

	Q2.	 Write the steps to freeze rows or columns in a worksheet.
	Ans.	 The steps to freeze rows or columns in a worksheet are as follows:

	 1.	 Open a new or existing workbook. 

	 2.	 Click the Freeze Panes button under the Window group in the View tab.

	 3.	 Select the desired option from the drop-down list. 

	Q3.	 What is the importance of page break in Excel?
	Ans.	 Page breaks are used in Excel to split a worksheet into multiple pages for printing. Microsoft Excel allows you to 

insert automatic page breaks on the basis of margin settings, paper size, scale options and the existing manual 
page break in the sheet. You need to adjust the page breaks in the worksheet to take the print out of worksheet 
on the desired number of pages. The automatically inserted page breaks are displayed with the dashed line 
while the solid line represents the manual page breaks on the worksheet. The page breaks can be inserted 
horizontally and vertically in the worksheet.
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	Q4.	 Write the steps to set the margins in a worksheet.
	Ans.	 The steps to set the margins in a worksheet are as follows:

	 1.	 Open a new or existing workbook.

	 2.	 Click the Margins button under the Page Setup group in the Page Layout tab. A drop-down list appears, 
displaying different options to set the margin.

	 3.	 Select the desired option from the drop-down list. The selected margin option is applied to the worksheet.

	Q5.	 What is the use of charts in Excel 2010?
	Ans.	 A chart is one of the best ways to present and analyse data visually. Charts make it easy for users to understand 

numerical data. In Microsoft Excel, you can create a broad range of customisable charts such as column charts, 
pie charts, surface charts and bubble charts. A chart is ideal for representing numbers and their relationship 
with one another. Microsoft Excel provides various options that allow you to change the appearance of a chart 
by adding elements such as a chart title, an axis title and a legend.

	Q6.	 Define filtering of data.
	Ans.	 Filtering of data refers to the process of retrieving specific data from a worksheet, which meets the criteria 

specified by a user. When you have a large chunk of data in a worksheet and want to display specific parts of 
it, you can do so by applying the Filter feature on the data. Filtering of data allows you to hide irrelevant data 
without actually deleting it from the worksheet. Filtering can be applied on textual as well as numeric data. As 
you know, the Filter option is available under the Editing group of the Home tab. When you select a single or 
multiple columns of data in a worksheet and apply filtering on the columns, down arrow buttons appear on each 
head of the selected columns. You can also display the down arrow buttons by selecting any cell in a worksheet 
and apply filtering on the cell. You can filter data in three ways: automatic filtering, filtering based on a specified 
condition and custom filtering.

	Q7.	 Write the steps to show how to set an axis title for a chart.
	Ans.	 The steps to show how to set an axis title for a chart are as follows:

	 1.	 Select the chart whose axis title you want to set.

	 2.	 Click the Axis Titles button under the Labels group in the Layout tab. A drop-down list appears.

	 3.	 Place the mouse pointer on the Primary Vertical Axis Title option in the drop-down list. Another drop-down 
list appears.

	 4.	 Select an axis for which you want a title, from the drop-down list. 

	 5.	 Type the axis title in place of the text Axis Title in the text box.

	Q8.	 Write the steps to assign a name to a range in a worksheet.
	Ans.	 The steps to assign a name to a range in a worksheet are as follows:

	 1.	 Open a new or existing workbook containing data. 

	 2.	 Select the cell or cell range to which you want to assign a name. 

	 3.	 Click the Define Name button under the Defined Names group in the Formulas tab.

		  The New Name dialog box appears.

	 4.	 Type the name for the range in the Name text box. 

	 5.	 Click the OK button.

		  The New Name dialog box gets closed and the name you assigned to the range appears in the Name Box located 
to the left of the Formula Bar.
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	Q9.	 What are the features available in the Freeze Panes button under the Window group?
	Ans.	 The features available in the Freeze Panes button under the Window group are as follows:

�� Freeze Panes: Allows you to freeze the rows and columns based on the current selected cell or range of cell 
while scrolling the rest of the worksheet

�� Freeze Top Row: Allows you to freeze the top row while scrolling the rest of the worksheet

�� Freeze First Column: Allows you to freeze the first column while scrolling the rest of the worksheet

	Q10.	Write the steps to insert the page break.
	Ans.	 The steps to insert the page break are as follows:

	 1.	 Open a workbook and enter some details into it. 

	 2.	 Select the desired cell for inserting the vertical and horizontal page break.

	 3.	 Select the Page Layout tab.

	 4.	 Click the Breaks button. A drop-down list appears.

	 5.	 Select the Insert Page Break option from the drop-down list.

		  The horizontal and vertical page breaks appear on the worksheet.

	 6.	 Click the Page Break Preview button in the status bar of the worksheet.

		  The Welcome to Page Break Preview dialog box appears.

	 7.	 Click the OK button.

Unit 5: Digital Presentation (Intermediate)
	Q1.	 Define animation.
	Ans.	 Animation refers to the process of creating a visual illusion of movement by quickly changing text matter or 

images in a sequence. These images can be hand-drawn, computer-generated or pictures of 3D objects.

	Q2.	 What do you understand by animation?
	Ans.	 Animation refers to the process of creating a visual illusion of movement by quickly changing text or images in 

a sequence. These images can be hand-drawn, computer generated, or pictures of 3D objects.

	Q3.	 Define transition in MS PowerPoint.
	Ans.	 Transition is a special effect that is about how one slide moves to another slide in the presentation and defines 

a way in which slides appear during a slide show. You can insert sound, manage the speed and even modify the 
properties of transition effects. It helps the presenter to better present the message by adding professional look 
and grab attention to specific important slides of the presentation.

	Q4.	 Define table and write the steps to add a table in the presentation.
	Ans.	 A table is a grid of cells created by the intersections of the corresponding rows and columns. It is used for a 

variety of tasks – from presenting numerical data to creating unique layouts.

		  The steps to add a table in the presentation are as follows: 

	 1.	 Select the Table W Insert Table option from the Insert tab.

		  	 The Insert Table dialog box appears.

	 2.	 Click the up or down arrow beside the Rows spin box to increase or decrease the number of rows.
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	 3.	 Click the up or down arrow beside the Columns spin box to increase or decrease the number of columns.

	 4.	 Click the OK button.

		  A table with specified number of rows and columns is inserted in the presentation.

	Q5.	 What do you mean by printing of a presentation?
	Ans.	 Printing is the one of the most important features of MS PowerPoint. Sometimes, it is essential for the presenters 

to share the content of the presentation in the printed format to the audience for the reference of the topic.

	Q6.	 Write the steps of inserting an audio clip in the slide in a presentation.
	Ans.	 The steps of inserting an audio clip in the slide in a presentation are as follows:

	 1.	 Select the slide in the Slides pane in which you want to add an audio clip.

	 2.	 Click the down-arrow of the Audio button under the Media group of the Insert tab. A drop-down list appears.

	 3.	 Select the Audio from File option from the drop-down list.

		  The Insert Audio dialog box appears.

	 4.	 Navigate to the location where the movie or sound files are stored in your computer.

	 5.	 Select the desired file.

	 6.	 Click the Insert button to insert the selected file in the slide.

		  Now, the selected audio clip is inserted in the slide.

	 7.	 Click the Play button to play the audio clip.

	Q7.	 Define charts in MS PowerPoint.
	Ans.	 Charts are an effective and efficient way of representing data in the graphical form. You can use elements, such 

as bars in a bar chart, and lines in a line chart to represent the data. A chart can also be used to represent the 
tabular numeric data in business and in organisations to make the presentation attractive and beneficial for the 
audience.

	Q8.	 What do you understand by grouping the objects in a slide?
	Ans.	 In PowerPoint, grouping the objects allows you to group two or more PowerPoint objects into single grouped 

object so that you can move them easily in a slide. You can also control the attributes of all the objects in a 
group at one time, such as adding a shape fill or effect, or an effect to a picture.

	Q9.	 Write the steps to insert speaker notes in slides.
	Ans.	 The steps to insert speaker notes in slides are as follows: 

	 1.	 Click the Notes Page button under the Presentation Views group of the View tab.

	 2.	 Type the desired notes in the text box.

	Q10.	Write some points to review the content in the presentation.
	Ans.	 The points to review the content in the presentation are as follows: 

�� Know your topic: Knowing your topic is important for you to be able to organise and present the topic 
and also to shape your presentation. There is nothing more significant, necessary and vital to presentation 
success than knowing your topic. Effective knowledge about the topic helps you deliver your idea in an 
easier and efficient way.

�� Use key phrases about your topic: Key phrases help the presenters to connect with their audience, so 
the audience easily remembers the important and relevant part of the topic. The relevant key phrases 
attract the audience and also make them more comfortable with the topic. Presenter key phrases should 
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be valuable, highly focussed and useful in order to make the presentation more productive and beneficial 
for the audience.

�� Avoid too much text on each slide: Good presenters do not use too much slides during their presentation. 
They only use slides to write bulleted points. So, they summarise their topic during the presentation 
according to them.

Unit 6: Email Messaging (Intermediate)
	Q1.	 What is calendar in MS Outlook?
	Ans.	 A calendar is the scheduling component that provides you with the facility for electronic time management, and 

information storage that you would expect to find in a paper-based appointment book.

	Q2.	 Define ‘note’ in MS Outlook.
	Ans.	 Notes are used to store important information that you do not want to forget or you might need later. You can 

use notes to write down your ideas, suggestions and questions.

	Q3.	 What do you understand by the month view of a calendar? Elaborate.
	Ans.	 The month view displays all the days within the current month with highlighting the current day. The month 

view includes three options to display the schedule of the entire month within your calendar:

�� Low: This option displays only the events in the calendar. Events are the items that are scheduled to last all 
day and do not have any specific start and end time.

�� Medium: This option displays events and appointments. Appointments are represented relative to the time 
of the day. A thin horizontal line extends through 12 noon in the cell for each day.

�� High: This option displays events and appointments. Appointments are listed with their start time, subject 
and location.

	Q4.	 What do you mean by sharing a calendar? Mention the different ways of doing it.
	Ans.	 MS Outlook 2010 includes a completely different feature that allows you to share your calendar information 

with others. To do this, Outlook provides you with many ways from which you can choose the one that best suits 
your requirements. Depending upon your work requirements, you can create any number of calendar folders 
and decide which folder you want to share. Usually, calendar-sharing depends upon the type of account and 
server you and the other recipients are using.

		  You can share a calendar in various ways, which are as follows:

�� Sharing a calendar through an e-mail

�� Sharing a calendar using Exchange server account

	Q5.	 What is the procedure to delete an appointment?
	Ans.	 Perform the following steps, to delete an appointment:

	 1.	 Select the appointment from the Calendar pane.

	 2.	 Click the Delete button under the Actions group of the Appointment tab.

		  The selected appointment gets deleted from the Calendar pane.

	Q6.	 How do you accept and decline an assigned task?
	Ans.	 When you receive an e-mail message containing a task, you can either accept the task or reject the task. By 

accepting or rejecting the task, you can inform the person, who has assigned you the task, whether you want 
to do the task or not. If you accept the task, an e-mail message regarding your acceptance is sent back to the 
person and the task is stored inside your Tasks folder. If you reject the task, an e-mail message regarding your 
rejection is sent back to the person; however, the task is not stored inside your Tasks folder.
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	Q7.	 What are the two advantages and disadvantages of journal?
	Ans.	 The two advantages of using a journal are as follows:

�� Verification of an email, sent or accepted, becomes easy

�� Computation of hours spent on a document to prepare the hourly wages

		  The two disadvantages of keeping a journal are as follows:

�� Too many journal entries result into a jammed mailbox

�� Unnecessary journal entries also get recorded

	Q8.	 Write the steps to share a calendar using exchange server account.
	Ans.	 The steps to share a calendar using exchange server account are as follows:

	 1.	 Select a calendar of the exchange server account that you want to share.

	 2.	 Click the Share Calendar button under the Share group of the Home tab.

		  A window appears that shows the calendar sharing options.

	 3.	 Enter the address of the recipients in the To text box.

	 4.	 Select the Allow recipient to view your Calendar check box.

	 5.	 Select the desired option from the Details drop-down list to specify the access permission. 

	 6.	 Enter the description for sharing calendar in the message area. 

	 7.	 Click the Send button.

		  The selected calendar gets shared with the specified recipient.

	Q9.	 Write the steps to decline a meeting request.
	Ans.	 The steps to decline a meeting request are as follows: 

	 1.	 Open the meeting request.

	 2.	 Click the Decline button under the Respond group of the Meeting tab.

		  A drop-down list appears.

	 3.	 Select the Send the Response Now option from the drop-down list.

	Q10.	Write the steps to customise the settings of the calendar.
	Ans.	 The steps to customise the settings of the calendar are as follows: 

	 1.	 Click the File tab. A Backstage View appears.

	 2.	 Select the Options option in the left pane of the Backstage View.

		  The Outlook Options dialog box appears.

	 3.	 Select the Calendar option in the left pane of the Outlook Options dialog box.

		  The settings related to calendar appear on the right side of the Outlook Options dialog box.

	 4.	 Modify the desired settings in the Outlook Options dialog box.

	 5.	 Click the OK button to save the modifications.

Unit 7: Database Development (Basic)
	Q1.	 Define data and information.
	Ans.	 Data is a collection of unorganised facts, such as symbols, alphabets or numbers, used for representing ideas 

and objects. The organised form of data is known as information.
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	Q2.	 What do you understand by database management system? 
	Ans.	 The application that controls the creation, maintenance and use of a database is known as Database Management 

System (DBMS). Some popular DBMS programs are Microsoft Access (MS Access), Microsoft SQL Server, Oracle 
and OpenOffice Base.

	Q3.	 Differentiate between data duplication and data inconsistency.
	Ans.	 As separate applications are used for separate data files, the same data is repeated again and again. It leads 

to the duplication of data. On the other hand, data inconsistency occurs when the same data that appears in 
different files is not updated simultaneously.

	Q4.	 What do you mean by classification of data?
	Ans.	 Classification refers to the procedure of dividing data into categories based on some defined circumstances. For 

example, in a bank, DBMS categorises the accounts in different categories, such as Savings, Current and Salary 
accounts.

	Q5.	 Define data redundancy. How DBMS reduces data redundancy?
	Ans.	 Duplication or repetition of data is known as data redundancy. As DBMS stores the data at a central location, 

it is easy to access or modify data. Also, any changes made in the data are reflected automatically and made 
available to all the users.

	Q6.	 What is the difference between DDL and DML in database?
	Ans.	 Data Definition Language (DDL) comprises SQL commands that are used for defining database schema. The 

commands in DDL can also manipulate the structure of database objects present in the database. Various 
examples of DDL commands are:

�� CREATE: This command is used in SQL to create various database objects such as tables, procedure, 
functions, etc.

�� DROP: This command is used to delete different objects present in a database.

�� ALTER: This command is used to modify the structure of a database.

		  Data Manipulation Language (DML) comprises commands that are used for manipulating data present in the 
existing database. Some commands of DML include:

�� SELECT: This command is used for retrieving data from a database.

�� INSERT: This command is used for inserting data into a table.

�� UPDATE: This command is used for updating existing data within a table.

�� DELETE: This command is used for deleting records from a database table.

	Q7.	 Describe the different components of a table with a suitable example.
	Ans.	 A table consists of a number of components, which are explained as follows:

�� Field: Refers to the smallest unit of information in a table. Each field in a table is given a unique name and 
a data type. Data type specifies the type of information that can be stored in a field. For example, consider 
a table named Employee_Details, which contains information about the employees of an organisation. You 
can have a field named Emp_Name, containing the name of employees. It should be noted that data types 
are predefined.

�� Primary key: Refers to a key that helps to uniquely identify a record in a table. The primary key is used to 
avoid duplicate data. In other words, a column with a primary key will not contain duplicate information in 
any of its records. For example, in the Employee_Details table, we can set the primary key in the Emp_Code 
column, which contains the employee code. In this case, duplicate values are not possible in the column.

�� Record: Refers to a row of data that represents a complete set of information in a table. For example, the 
record of an employee contains all information about him/her, such as employee code, name, address, salary, 
etc.
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	Q8.	 Write the steps to create a report using the Report tool.
	Ans.	 The steps to create a report using the Report tool are as follows: 

	 1.	 Open the database in which you want to create a report.

	 2.	 Select the desired table from the Navigation Pane.

	 3.	 Select the Create tab on the Ribbon.

	 4.	 Click the Report button under the Reports group in the Create tab.

	 5.	 The report is created and appears in the Layout view.

	Q9.	 Write the steps to save a query.
	Ans.	 The steps to save a query are as follows:

	 1.	 Click the File tab on the Ribbon. A Backstage view appears.

	 2.	 Select the Save option to save the query.

		  The Save As dialog box appears.

	 3.	 Type the name with which you want to save your query under the Query Name text box.

	 4.	 Click the OK button.

	Q10.	Describe the advantages of using DBMS.
	Ans.	 The advantages of using DBMS are as follows:

�� Reduces data redundancy: Duplication or repetition of data is known as data redundancy. As DBMS stores 
the data at a central location, it is easy to access or modify data. Also, any changes made in the data are 
reflected automatically and made available to all the users. As the changes are made at only one location, 
chances of data redundancy are greatly reduced.

�� Allows data sharing: The facility to use or share the same data or data resource with multiple users is 
known as data sharing. In DBMS, all data is stored at a central location from where users can easily access 
it simultaneously.

�� Enforces database standards: DBMS ensures that the data stored in it follows certain applicable standards. 
These standards are set by an organisation or a person who has created the database. Setting such standards 
helps in transferring the data from one system to another.

�� Backup and recovery: DBMS provides the backup and recovery facilities to protect data from hardware or 
software failures. The backup is the copy of data that can be used for future references for the purpose of 
recovery of the database.


